Shade3D オンラインヘルプ [目次]

点群(入出力、編集、ポリゴンメッシュ化)

Basic Standard Professional Civil Ultimate
- - O O O

3Dスキャナなどで取り込んだ点群データの読み込み、表示、編集やポリゴンメッシュ生成に対応しました。
点群データファイルをインポートすると、新規形状タイプの「点群」として生成されます。
点群は断面などをそのままモデリングのテンプレートとしたり、ポリゴンメッシュに変換するなどして利用できます。
点群はポイントの座標のほか、法線、カラーの情報を保持することができます。
点群の生成はインポートのみとなります。(SDK, スクリプトによる新規の点群生成は可能)
点群データは「点群」ツールにより編集を行えます。

注意レンダリングには反映されません。
注意表面材質の設定は反映されません。
注意形状編集モードでの点ごとの選択、編集には対応していません。

重要Professional / Civil / Ultimateで使用できる機能です。

・ファイルI/O
メインメニュー「ファイル」 > 「インポート」 > 「点群(pcd/ply/pts/xyz/xyzn/xyzrgb)...」
メインメニュー「ファイル」 > 「エクスポート」 > 「点群(pcd/ply/pts/xyz/xyzn/xyzrgb)...」
・[点群]編集ツール
メインメニュー「表示」 > 「編集[点群]ツールボックス」
メインメニュー「ツール」 > 「編集[点群]」


動作環境

環境動作
WindowsAVXに対応したCPU(Sandy Bridge以降)
macOS必須モデルを満たすハードウェア

参照Ver.24動作環境

「形状情報」ウインドウ

「表示属性」グループ
図面での表示の設定を行います。
「ワイヤフレーム」テキストボックス、スライダ
ワイヤフレーム表示の図面に表示する点の割合を設定します。
デフォルトでは全体の1割が表示されます。
「シェーディング」の数値よりも大きくすることはできません。
左から 0.0、0.25、0.5、0.75、1.0 / シェーディング:1.0
「シェーディング」テキストボックス、スライダ
シェーディング表示の図面に表示する点の割合を設定します。
デフォルトでは全ての点が表示されます。
「ワイヤフレーム」の数値よりも小さくすることはできません。
左から 0.1、0.25、0.5、0.75、1.0 / ワイヤフレーム:0.1
「ポイントサイズ」テキストボックス、スライダ
描画する点のサイズをピクセル単位で指定します。
上段:左から 1.0、1.2、1.3、1.4、1.5 下段:左から 2.0、4.0、6.0、8.0、10.0

「点群情報」グループ
「点群」の情報や要素の削除を行います。
「ポイント」
点群が保持しているポイント数を表示します。
「法線」
点群が法線情報を保持しているかどうかを表示します。保持している場合は「YES」、していない場合は「NO」が表示されます。
「削除」
法線情報を削除します。
「カラー」
点群がカラー情報を保持しているかどうかを表示します。保持している場合は「YES」、していない場合は「NO」が表示されます。
「削除」
カラー情報を削除します。

図面表示

ワイヤフレーム/図面
形状情報の「ワイヤフレーム」で指定された量の点が表示されます。
点群のカラー情報は反映されません。
「表示オプション」の「法線を表示」がオンのとき、法線の向きが線で表示されます。
シェーディング/テクスチャ
形状情報の「シェーディング」で指定された量の点が表示されます。
「フォン」が選択されているとき、カラー情報が反映されます。
「法線」が選択されているとき、法線の向きが色で表示されます。
シェーディング+ワイヤフレーム/テクスチャ+ワイヤフレーム
形状情報の「シェーディング」で指定された量の点が表示されます。
「フォン」が選択されているとき、カラー情報が反映されます
「法線」が選択されているとき、法線の向きが色で表示されます。
「表示オプション」の「法線を表示」がオンのとき、法線の向きが線で表示されます。

プレビューレンダリング、GPUレイトレーシングの図面では点群は描画されません。

光源、表面材質の設定は反映されません。常に点群が保持している色で描画されます

「切断面設定」「切断」機能への対応

「切断面設定」機能による断面表示、「切断」ツールの一部の機能に対応しています。

切断位置 「断面表示」 「切断」ツール
選択形状 ○ 切断のみ
座標値 ○ 切断のみ
平面指定 × ×
ボックス × ×

インポート

「sRGBカラースペース」チェックボックス
オンのとき、色情報をsRGBカラースペースとして読み込みます。
sRGB以外のカラースペースや、色の代わりに別の情報を入れている場合はオフにします。

対応情報

形式 拡張子 法線 カラー 備考
Point Cloud Data pcd ○ ○
Stanford PLY ply ○ ○ 点群のみを読み込む(メッシュなどのデータは無視)
Leica PTS pts × ○
XYZ xyz × ×
XYZN xyzn ○ ×
XYZRGB xyzrgb × ○

デフォルトでは座標値をm単位、Z-Upで読み込みます。

ファイルの点群データは一つの点群形状として読み込まれます。

エクスポート

「形式」ポップアップメニュー
出力するファイルの形式を選択します。「Point Cloud Data(pcd)」、「Stanford PLY(ply)」、「Leica PTS(pts)」、「XYZ(xyz)」、「XYZN((xyzn)」、「XYZRGB(xyzrgb)」から選択します。
「圧縮」チェックボックス
オンのとき、圧縮されたデータとして出力します
ファイルサイズが小さくなりますが、読み込み側のツールが圧縮形式に対応している必要があります。
「sRGBカラーで出力」チェックボックス
オンのとき、色情報をsRGBカラースペースとして保存します。
sRGB以外のカラースペースや、色の代わりに別の情報を入れている場合はオフにします。

デフォルトでは座標値をm単位、Z-Upで保存します。

出力対象の点群データをすべてまとめて一つの点群ファイルとして保存します。

[点群]編集ツール

「結合」
2つ以上の点群形状を選択しているとき有効となります。
選択している複数の点群形状を統合して1つの点群形状にします。
「切断」
点群形状をドラッグした線で切除します。
ドラッグの開始点を基準とした線の進行方向の右側が削除されます。
▶
「分離」
点群形状をドラッグした線で分離します。
▶
「断面の抽出」
点群形状をドラッグした線で指定した線幅分の断面を抽出します。
▶
ツールパラメータ
「幅」テキストボックス
抽出する幅(線を中心とした幅)を指定します。
「元の形状を非表示にする」チェックボックス
オンのとき、断面抽出後に抽出元の点群形状を非表示にします。
「クラスタの分離」
点群を自動で部品分けして、複数の形状に分離します。
▶
ツールパラメータ
「探索半径」テキストボックス
一つの部品として判定する最大距離を指定します。
値を大きくするほど処理に時間がかかります。
「最小点数」テキストボックス
一つの部品として判定する最小の点数を指定します。
「ダウンサンプリング」
点群のポイント数を削減します。
▶
ツールパラメータ
「ボクセルサイズ」テキストボックス
指定した間隔ごとにポイントを統合してポイント数を減らします。
値を大きくするほどポイントの数が減ります。
「法線を反転」
点群が法線を保持しているとき、有効となります。
点群の法線を反転します。
▶
TIPS部分的に反転するには「切断」で分割後に法線を反転し「結合」で再結合します。
「法線計算」
点群を解析して、ポイントに法線を設定します。
ポリゴンメッシュ生成のための前処理として実行します。
▶
ツールパラメータ
「処理」ポップアップメニュー
実行する処理を選択します。「法線計算」、「ポリゴンメッシュ生成」から選択します。
「法線計算」グループ
「処理」ポップアップメニューで「法線計算」が選択されているとき、有効となります。
「探索半径」テキストボックス
法線の推定に利用するポイントの探索範囲を設定します。
値を大きくすると精度が高くなりますが、処理にかかる時間が多くなります。
「近傍点数」テキストボックス
法線の推定に利用するポイントの数を設定します。
値を大きくすると精度が高くなりますが、処理にかかる時間が多くなります。
「法線統一」チェックボックス
オンのとき、法線計算の実行後、法線の向きを統一します。
オンにすると法線の向きのばらけが少なくなりますが、処理に時間が多くかかります。(ばらけが残る場合もあります。)
「ポリゴンメッシュ生成」グループ
「処理」ポップアップメニューで「ポリゴンメッシュ生成」が選択されているとき、有効となります。
「ポリゴンメッシュ生成」
点群からポリゴンメッシュを生成します。
法線情報を保持していない点群形状に対して実行すると、自動で「法線計算」もが行われます。
▶
ツールパラメータ
「処理」ポップアップメニュー
実行する処理を選択します。「法線計算」、「ポリゴンメッシュ生成」から選択します。
「法線計算」グループ
「処理」ポップアップメニューで「法線計算」が選択されているとき、有効となります。
「ポリゴンメッシュ生成」グループ
「処理」ポップアップメニューで「ポリゴンメッシュ生成」が選択されているとき、有効となります。
「深度」テキストボックス
ポリゴンメッシュ生成の精度を設定します。
値を大きくすると精度が高くなりますが、処理にかかる時間と生成されるポリゴン数が多くなります。
「表面材質を設定する」チェックボックス
点群がカラー情報を保持しているとき、有効となります。
オンのとき、生成されたポリゴンメッシュに表面材質(マッピングに頂点カラーを設定)を割り当てます。
「元の形状を非表示にする」チェックボックス
オンのとき、処理後に生成元の点群形状を非表示状態にします。
ポリゴンメッシュの生成の処理中はプログレスダイアログの更新が行われないため、「深度」の値が大きいと「応答なし」の状態が長時間続く場合があります。
法線の向きの精度が低い場合や、統一されていない場合はポリゴンメッシュの生成の精度が低くなるため、各ツールを使用して法線を整えると良好な結果が得やすくなります。

Copyright © 1986-2026 FORUM8 Co., Ltd.